[GreatFET] Not detected on Windows 7

Dillon Nichols ee.tinkerer at gmail.com
Wed May 22 10:41:04 EDT 2019


Thanks! I did get it working after digging into it.

I installed the drivers alright with Zadig. I created a PR against the
tutorials with your explanation so others can find it:

I ran through the instructions to install greatfet from git and made
another PR to explain some details that weren't immediately clear:

I noticed that the libgreat submodule inside greatfet was out of date so I
pulled from master there (which seems to be your Windows fix). I also
needed to uninstall the old version of pygreat so it picked the dev
version. These probably won't be issues once the code is released, but this
tripped me up for a while.

Thanks again for your help,

On Tue, May 21, 2019 at 7:17 PM Kate Temkin <k at ktemkin.com> wrote:

> Hi, Dillon:
> There is a Windows driver for GreatFET -- we actually rely on one of the
> generic USB drivers for Windows; which often needs a little help to wind up
> installed and bound to the relevant device. For now, the easiest way to do
> that is to use the Zadig utility to bind the "libusb-win32" driver to the
> GreatFET device. There's a generic tutorial here:
> https://github.com/pbatard/libwdi/wiki/Zadig; you'll need to select the
> GreatFET device and select "libusb-win32" as the driver to bind to.
> Note that the distribution of our "pygreat" library currently on pip has
> an communication issue in some Windows environments-- the relevant issue
> has been fixed in master. If you run into an issue where e.g. "greatfet
> info" suggests that there's a "problem with a device connected to the
> system" (or a similarly vague error message), you may want to install the
> latest host tools from git (instructions:
> https://github.com/greatscottgadgets/greatfet/blob/master/host/README.md).
> Those fixes should be included in a software release in the near future.
> Let me know if that works for you. :)
> --Kate
> On Fri, May 17, 2019 at 7:29 AM Dillon Nichols <ee.tinkerer at gmail.com>
> wrote:
>> Hey all,
>> Just bought a GreatFET One and I'm trying to use it in Windows 7. I
>> followed the Getting Started Guide
>> https://greatscottgadgets.github.io/greatfet-tutorials/getting-started.html to
>> install the utility with admin rights. Now when I run `greatfet info`, it
>> responds with `No GreatFET devices found!`. I can see in Device Manager \
>> Other devices, something called GreatFET and the board LED is blinking. Is
>> there a Windows driver for this device? Am I missing something else?
>> Thanks!
>> Dillon
>> _______________________________________________
>> GreatFET mailing list
>> GreatFET at greatscottgadgets.com
>> https://pairlist3.pair.net/mailman/listinfo/greatfet
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://pairlist3.pair.net/pipermail/greatfet/attachments/20190522/bc55296a/attachment.html>

More information about the GreatFET mailing list